VCSA 6.5 update fails with “vix error codes = (1, 4294967294)”

Last week I performed a VCSA upgrade from 6.0U2 to the latest 6.5 version. Already in Stage 1, where I needed to connect to the source appliance I got the error “A problem occurred while getting data from the source vCenter Server” from the installer (like you can see on the screenshot).

The attached log file showed the following line at the end:

2017-12-14T09:30:28.673Z – error: sourcePrecheck: error in getting source Info: ServerFaultCode: A general system error occurred: vix error codes = (1, 4294967294)

It turned out that this error was related to a root password of the old appliance, which was about to expire (but didn´t so far). Anyway, the easy workaround here was just to change the root password on the old appliance to a new one. Durring the process of the installer you are asked for a “new” root password for the new VCSA appliance anyway, so you can directly use the old password again if you like to.
Maybe also a good time to consider disabling the root password expiration after the update, if you run into the same problem.

Speak Your Mind

*